Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

Thảo luận trong 'Truyền hình HDTV' bắt đầu bởi tienthanhbk, 16/4/14.

  1. vuthecong78

    vuthecong78 Well-Known Member

    Tham gia ngày:
    6/2/13
    Bài viết:
    1,191
    Đã được cảm ơn:
    85
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Với sự trợ giúp qua Teamviewer và sửa thêm chút ở file udpxy. Tất cả đã như ý: MyTV STB ở LAN 4, các LAN khác và Wifi có Internet + IPTV đi kèm.
    Cảm ơn anh hamzuii rất nhiệt tình.
     
    Chỉnh sửa cuối: 3/10/15
  2. tuanqc78

    tuanqc78 Well-Known Member

    Tham gia ngày:
    9/3/13
    Bài viết:
    1,025
    Đã được cảm ơn:
    158
    Giới tính:
    Nam
    Re: Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Bác Công giờ chơi cả STB nửa à, không phải dùng gói free theo cáp quang sao. Có STB rồi bác chịu khó dò sửa lại mấy kênh trong list củ không chạy được.
     
  3. vuthecong78

    vuthecong78 Well-Known Member

    Tham gia ngày:
    6/2/13
    Bài viết:
    1,191
    Đã được cảm ơn:
    85
    Ðề: Re: Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    STB được họ cho nên để nghịch ngợm chút thôi.
     
  4. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Config của Công là do thay đổi tên interface của iptv từ eth0.2405 => br-iptv, thực ra nó chỉ ảnh hưởng tới cái udpxy. Từ đầu Công mà thử list udp thì a đã đoán ra ngay bị gì rồi.

    Cài thử bản 15.05 a build ở trên đi, có udpxy chỉnh = Luci rất tiện.
     
  5. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Em update lên phiên bản 15.05 thì mất Multicast ở cổng 4 lẫn udpxy dù cấu hình vẫn còn nguyên. Trước đó bản 14.07 vẫn bình thường. Em dùng AG300H. Không biết có bác nào bị không nhỉ ?
     
  6. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Up lên thì mặc định nó đâu có sẵn các gói igmpproxy & udpxy đâu mà chạy đc, bạn phải cài = tay 2 cái đó vô rồi mới restore lại cấu hình.
     
  7. vuthecong78

    vuthecong78 Well-Known Member

    Tham gia ngày:
    6/2/13
    Bài viết:
    1,191
    Đã được cảm ơn:
    85
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Để hôm khác em rảnh rồi thử.
    Anh build luôn vài firmware cho mấy con 740, 741, 841, 4300 đi anh. Có kèm mấy gói cho IPTV ấy và đưa cả wifi vào nữa.
    THANK YOU SO MUCH.
     
  8. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Em đã cài lại tất cả các gói. Cấu hình vẫn y chang như bản 14.07. Mỗi lần Enable interface LAN hay IPTV thì nó chạy được tí xíu rồi dừng lại. igmpproxy & udpxy thì vẫn start bình thường. Nhưng không có xem được tín hiệu Multicast ở cổng 4 hay IPTV ở Wi-Fi hay LAN khác
     
  9. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Mấy con flash 4MB cài 15.05 là gần như ko còn dư để cài thêm cái gì nữa đâu, quên nó đi.

    Bạn nên post đầy đủ cấu hình: network, firewall, igmpproxy, udpxy lên thì mới giúp được.
     
  10. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Kính nhờ các bác xem giúp em cấu hình cho con AG300H chạy FW OpenWRT 15.05
    Mọi thứ ổn cả với 14.07. Nhưng với cấu hình này ở 15.05 thì không xem được IPTV ờ tất cả các giao thức. Internet thì vẫn truy cập bình thường.
    VLAN 11 là của Internet
    VLAN 12 là của IPTV
    network
    Mã:
    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'fd2b:b595:a18d::/48'
    
    config interface 'lan'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option delegate '0'
    	option stp '1'
    	option _orig_ifname 'eth0 radio0.network0 radio1.network1'
    	option _orig_bridge 'true'
    	option ipaddr '192.168.1.1'
    	option igmp_snooping '1'
    	option ifname 'eth0.1 eth0.12'
    
    config interface 'wan'
    	option _orig_bridge 'false'
    	option ifname 'eth1.11'
    	option proto 'pppoe'
    	option username 'aaa'
    	option password 'bbb'
    	option peerdns '0'
    	option dns '8.8.8.8 208.67.222.222'
    	option delegate '0'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option vid '1'
    	option ports '0t 2 3 4'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '2'
    	option ports '0t 1'
    	option vid '12'
    
    config interface 'iptv'
    	option type 'bridge'
    	option _orig_ifname 'eth1.12'
    	option _orig_bridge 'true'
    	option ifname 'eth0.12 eth1.12'
    	option proto 'dhcp'
    	option delegate '0'
    	option defaultroute '0'
    	option peerdns '0'
    
    firewall
    Mã:
    config defaults
    	option syn_flood '1'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'REJECT'
    
    config zone
    	option name 'lan'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'ACCEPT'
    	option network 'lan'
    
    config zone
    	option name 'wan'
    	option output 'ACCEPT'
    	option masq '1'
    	option mtu_fix '1'
    	option network 'wan wan6'
    	option input 'REJECT'
    	option forward 'REJECT'
    
    config zone
    	option name 'iptv'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'ACCEPT'
    	option network 'iptv'
    
    config forwarding
    	option src 'lan'
    	option dest 'wan'
    
    config rule
    	option name 'Allow-DHCP-Renew'
    	option src 'wan'
    	option proto 'udp'
    	option dest_port '68'
    	option target 'ACCEPT'
    	option family 'ipv4'
    
    config rule
    	option name 'Allow-Ping'
    	option src 'wan'
    	option proto 'icmp'
    	option icmp_type 'echo-request'
    	option family 'ipv4'
    	option target 'ACCEPT'
    
    config rule
    	option src 'iptv'
    	option proto 'igmp'
    	option target 'ACCEPT'
    
    config rule
    	option src 'iptv'
    	option proto 'udp'
    	option dest 'lan'
    	option dest_ip '224.0.0.0/4'
    	option target 'ACCEPT'
    
    config rule
    	option src 'iptv'
    	option proto 'udp'
    	option dest_ip '224.0.0.0/4'
    	option target 'ACCEPT'
    
    config include
    	option path '/etc/firewall.user'
    
    config rule
    	option enabled '1'
    	option target 'ACCEPT'
    	option proto 'tcp udp'
    	option dest_port '6600'
    	option name 'mpd'
    	option src '*'
    	option dest '*'
    
    igmpproxy
    Mã:
    config igmpproxy
    	option quickleave 1
    
    config phyint
    	option network iptv
    	option direction upstream
    	list altnet 0.0.0.0/0
    
    config phyint
    	option network lan
    	option direction downstream
    	list altnet 192.168.1.0/24
    udpxy
    Mã:
    config udpxy
    	option verbose '0'
    	option status '1'
    	option bind 'br-lan'
    	option port '4022'
    	option source 'br-iptv'
    	option max_clients '5'
    	# option log_file '/var/log/udpxy'
    	option buffer_size '4096'
    	# option buffer_messages '-1'
    	# option buffer_time '-1'
    	# option nice_increment '0'
    	# option mcsub_renew '0'
    
     
    Chỉnh sửa cuối: 6/10/15
  11. vuthecong78

    vuthecong78 Well-Known Member

    Tham gia ngày:
    6/2/13
    Bài viết:
    1,191
    Đã được cảm ơn:
    85
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Hai chỗ này có vẻ lộn xộn nhỉ
     
  12. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Đoạn này của file network bạn bridge sai rồi:
    Mã:
    config interface 'lan'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option delegate '0'
    	option stp '1'
    	option _orig_ifname 'eth0 radio0.network0 radio1.network1'
    	option _orig_bridge 'true'
    	option ipaddr '192.168.1.1'
    	option igmp_snooping '1'
    	option ifname [B]'eth0.1 eth0.12'[/B]
    Xóa cái eth0.12 đi. Tất cả cấu hình còn lại đều ổn.
     
  13. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Cám ơn bác hamdzui. Bác có thể cho em xin file cấu hình con Router của bác chạy Firmware OpenWRT 15.05 để em tham khảo được không ạ ?
     
  14. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Của tớ y chang bạn ko khác gì cả.
     
  15. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Vậy mà cấu hình này thì trên 14.07 em xem mọi thứ ổn cả. Còn lên 15.05 thì chỉ có Internet chạy. Kể cả quay VPN về cơ quan qua máy tính bắt Wi-Fi cũng chẳng được. Nên em muốn tham khảo có ai đã lên 15.05 mà chạy được IPTV qua igmpproxy và udpproxy chưa.
     
  16. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Túm lại xóa cái "eth0.12" đi thì chạy đc chưa ? Ở 14.07 chạy đc là bạn đã gặp may, chứ căn bản cấu hình như vậy là trật lất rồi.
     
  17. tuyenda1985

    tuyenda1985 Member

    Tham gia ngày:
    6/7/14
    Bài viết:
    68
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Các bác tư vấn em phát:
    Mô hình line viettel 30m và line fpt 10m. Thiết bị có router viettel acatel và modem wifi fpt và ag300h (fw openwrt 14.7). Nối viettel và fpt vào ag300h
    Y/c :
    1 - đường lan ag300h có thể download tổng 40m ( loadblance)
    2 - đường lan ag300h xem iptv simple (openelec) chạy được list m3u của fpt ( nhìn thấy lis toàn dạng link upd://

    Đã làm được :
    - mutilwan sử dụng mwan3 => loadblance xong
    - iptv tịt không chạy được. Không biết có cần cài updxy cho ag300h không các bác? Nếu cần thì bác nào có hướng dẫn giúp em với

    P/s em đã thử nối router fpt vào wan tplink 740n (fw factory) rồi lan 740n cấp ip cho pi2 (fw openelec) vẫn xem được iptv simple sử dụng list m3u của fpt
     
  18. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Vẫn chưa được bác hamdzui ơi. Bấm vào nút connect trong phần Interface thì xem được tí xíu rồi không xem IPTV được nữa. Bác có dùng AG300H không và chạy FW mấy rồi ạ ?
     
  19. hamdzui

    hamdzui Member

    Tham gia ngày:
    5/5/10
    Bài viết:
    111
    Đã được cảm ơn:
    0
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Bấm vô connect chi trời ? tất cả đều tự động, reboot lại router mọi thứ sẽ tự chạy ko phải can thiệp gì cả. Xem lại thật kỹ cấu hình của bạn đi, tớ xài 15.05 nửa năm nay rồi có bị gì đâu.
     
  20. Silver Nano

    Silver Nano Member

    Tham gia ngày:
    2/6/09
    Bài viết:
    49
    Đã được cảm ơn:
    5
    Ðề: Hướng dẫn cài đặt UDPXY trên các dòng Buffalo Wireless Router có USB chạy DD-WRT

    Bác dùng con gì ạ ?. 15.05 này cần cấu hình khác 14.07 hay hay gói opkg nào khác chăng ?. Cho em xem cấu hình với. Loay hoay cả mấy tuần, lên rồi xuống mà chẳng được.
    Em đành phải về 14.07 để xem IPTV với STB trên cổng 4 và udpproxy qua Wi-Fi. Lên 15.05 không xem IPTV được.
    Em lấy con TP-LINK 740 lên 15.05 cũng tình trạng tương tự.
     

Chia sẻ trang này